mySNHU - Emergency Contact
Incident Report for SNHU System Status Page
Resolved
The previously reported issues with the emergency contact form in mySNHU have been resolved. ITS continues to monitor.
Posted Aug 18, 2022 - 17:27 EDT
Update
We are continuing to investigate this issue.
Posted Aug 18, 2022 - 08:41 EDT
Investigating
Customers completing the emergency contact form in mySNHU may see errors related to email address already in use. ITSD are aware and investigating.
Posted Aug 18, 2022 - 08:41 EDT
This incident affected: mySNHU.