Outlook.com
Incident Report for SNHU System Status Page
Resolved
Microsoft has reverted a change and this issue has been resolved. ITS continues to monitor.
Posted Jun 05, 2023 - 12:57 EDT
Investigating
Some customers may be experiencing slowness or "Service Unavailable" errors when accessing outlook.com. ITS are awaiting updates from Microsoft. This can also be monitored from the Microsoft status page: https://portal.office.com/servicestatus
Posted Jun 05, 2023 - 11:23 EDT
This incident affected: Email.