Turnitin is experiencing a service interuption
Incident Report for SNHU System Status Page
Resolved
This incident has been resolved.
Posted Nov 02, 2023 - 12:48 EDT
Monitoring
TurnItIn service has been restored. If you experienced a timeout or other issues when trying to use TurnItIn since this morning, please retry.
Posted Nov 02, 2023 - 11:49 EDT
Investigating
TurnItIn is experiencing a service interruption that began this morning around 8 AM. TurnItIn status can be found at: https://turnitin.statuspage.io/
During this time, you may find that you are unable to log in or access reports. Users accessing these services via an integration like Brightspace may also be affected.

We will update this status as we have more information on an estimated time of restoration or when it is restored.
Posted Nov 02, 2023 - 11:08 EDT
This incident affected: Brightspace Learning Environment.