Brightspace not displaying or 'Missing' courses
Incident Report for SNHU System Status Page
Resolved
The issue affecting some Brightspace users seeing their courses has been resolved. ITS will continue to monitor.
Posted Sep 18, 2023 - 12:43 EDT
Investigating
We are currently investigating this issue.
Posted Sep 18, 2023 - 10:10 EDT
This incident affected: Brightspace Learning Environment.