Brightspace - Internal Error
Incident Report for SNHU System Status Page
Resolved
Access to Brightspace is now functional. ITS continues to monitor.
Posted Sep 27, 2021 - 02:30 EDT
Identified
Students attempting to access Brightspace are experiencing an "Internal Error." ITS is working to resolve the issue with the utmost urgency.
Posted Sep 27, 2021 - 01:54 EDT
This incident affected: Brightspace Learning Environment.