mySNHU
Incident Report for SNHU System Status Page
Resolved
Issues with accessing mySNHU for online students have been resolved. If you continue to experience issues, please contact the Service Desk.
Posted Jul 21, 2022 - 16:06 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 21, 2022 - 16:05 EDT
Identified
At this time, the Service Desk are aware of intermittent issues loading the mySNHU site as well as some limited functionality. While our teams are actively working to resolve this, the following links have been provided as a workaround if needed to access Brightspace or webmail:

Brightspace: learn.snhu.edu
Webmail: webmail.snhu.edu

ITS are continuing to investigate this issue.
Posted Jul 21, 2022 - 11:37 EDT
This incident affected: mySNHU.