Brightspace Slowness and Internal Error
Incident Report for SNHU System Status Page
Resolved
This incident has been resolved.
Posted Feb 26, 2023 - 16:15 EST
Update
We are continuing to monitor for any further issues.
Posted Feb 26, 2023 - 15:24 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2023 - 13:59 EST
Investigating
Brightspace is experiencing an internal error causing slow loading times and error messages when navigating for students and faculty. D2L has confirmed the slowness and is working to restore functionality ITS is investigating.
Posted Feb 26, 2023 - 13:06 EST
This incident affected: Brightspace Learning Environment.