Brightspace Internal Error
Incident Report for SNHU System Status Page
Resolved
This incident has been resolved and ITS continues to monitor.
Posted Oct 18, 2021 - 11:09 EDT
Investigating
Brightspace is experiencing an internal error causing slow loading times and error messages at login. ITS is investigating with Brightspace.
Posted Oct 18, 2021 - 10:24 EDT
This incident affected: Brightspace Learning Environment.