Brightspace
Incident Report for SNHU System Status Page
Resolved
Brightspace is now accessible via learn.snhu.edu. Please reach out to the Service Desk if you are experiencing any access issues.
Posted Nov 10, 2021 - 16:15 EST
Identified
Customers are experiencing issues accessing Brightspace via learn.snhu.edu. In the interim, please access Brightspace using the link from my.snhu.edu. ITS are investigating the issue.
Posted Nov 10, 2021 - 15:50 EST
This incident affected: Brightspace Learning Environment.