Bookstore is experiencing a service interruption with the page saying "We're Down"
Incident Report for SNHU System Status Page
Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 15:57 EDT
Monitoring
The Bookstore webpage and service have been restored. We will continue to monitor this.
Posted Mar 13, 2023 - 10:10 EDT
Update
We are continuing to investigate this issue.
Posted Mar 12, 2023 - 20:10 EDT
Investigating
The BNC Bookstore is experiencing an Outage with the page saying "we're down" after planned maintenance between Mar 11th and Mar 12th.
Posted Mar 12, 2023 - 20:09 EDT
This incident affected: SNHU Online Bookstore.