BNC Bookstore Login Loop
Incident Report for SNHU System Status Page
Resolved
This issue is currently resolved. If you continue to have issues accessing the Bookstore, please do not hesitate to reach out to the IT Service Desk. We will continue to monitor.
Posted Jan 24, 2024 - 17:19 EST
Update
We are continuing to investigate this issue.
Posted Jan 24, 2024 - 17:18 EST
Investigating
BNC Bookstore is experiencing an issue when users are receiving a login loop and unable to successfully log in to the Bookstore. We are aware and investigating.
Posted Jan 24, 2024 - 14:18 EST
This incident affected: SNHU Online Bookstore.